22 Mar 2016 @ 1:05 PM 

I have been developed using ASP.NET 2.0 using Visual Studio 2010 using VB. Reason why I stick to use ASP.NET 2.0 is because my hosting provider only support ASP.NET version 2.0 and 4.0 and I feel the former is more light and normally come installed in Windows 7.

All the while, I am happy developed in Windows 7 until I upgraded to Windows 10 yesterday. It has turned to disaster that my Ajax controls are no longer working. In the designer, it showed Error Creating Control and the description is pointing to AjaxControlToolkit which may not configured properly.

Error Creating Control - ToolkitScriptManager1
Failed to create designer 'AjaxControlToolkit.ToolkitScriptManager, AjaxControlToolkit, 
Version=1.0.20229.20821, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e'

asp-net-2-0-ajax-control-toolkit-1-0-win-10-visual-studio-2010

I tried to search on the Internet but could not find any solution that worked. I tried to edit my Web.Config file and it didn’t help. I tried to reinstall ASPAJAXExtSetup.msi but the problem is still persist. I tried to switch the target framework to version 3.5 and it is working but this is not what I wanted.

Finally, I found the solution by adding a reference to System.Web.Extensions.Design

project-references-system-web-extensions-design

Hope this article can help those who are facing the same problem as me.

Posted By: Aeric
Last Edit: 22 Mar 2016 @ 01:22 PM

EmailPermalinkComments (0)
Tags
 11 Nov 2015 @ 10:21 PM 

This article explains what most beginners of PHP are wondering:
http://www.robert-gonzalez.com/2009/03/04/php-operators-double-and-single-arrow/

<?php
$obj = new MyObject();
$obj->thisProperty = 'Fred';
$obj->getProperty();
?>
<?php
$myArray = array(
'Robert' => 'Big',
'Bobby' => 'Smart',
'PHP' => 'Rocks'
);
?>
<?php
MyClass::$staticProperty = 'Fred';
MyClass::getStaticProperty();
?>
Posted By: Aeric
Last Edit: 11 Nov 2015 @ 10:30 PM

EmailPermalinkComments (0)
Tags
Categories: Cyberticles, Cyblog, Links, Projects
 08 Nov 2015 @ 12:09 AM 

laravel5

I decided to give laravel a go. I am not expert in php development but I hope this php framework can help me learn how to build a php website in a rapid way.

First, I was trying to use Vagrant or Homestead in windows as suggested but end up I gave up due to big file download and failed at the end.

Then I found Laragon. It is a very good software for windows. I was able to install it easily in Windows 10 and follow a few chapters in tutorial.

A few days ago, my iPro Livepad volume rocker has problem so I decided to use my old Asus laptop as my development machine. I re-formatted the Ubuntu 9.10 to 14.04 and try to install all the requirements to get laravel 5.1 to work.

Learning laravel 5 is not an easy journey for VB programmer like me who spend most of time with windows platform. I have little knowledge in ubuntu and document structure in linux environment.

I found some challenges in running laravel in linux system. First I need to understand how to use sudo command and deal with file permission. However, typing these commands in terminal is not a problem for me. Then I found not much tutorial on setting up laravel in ubuntu lamp. Instead, I found it is quite strange that there are more tutorials using vagrant, wamp or xamp.

Then I found tutorial that lead me to install ‘laravelnew’ in /var/www/html/laravelnew. I tried to change the web browser URL to http://localhost/laravelnew but this is not working. The correct laravel welcome page is accessible by browsing http://localhost/laravelnew/public. I search through the internet and found many people like me struggle to get it work by changing the .htaccess file, server.php, /etc/apache2/apache2.conf file and setting up virtual host in order to remove the public folder from the path. I searched for whole day but I can’t find a good solution. The basic routing is not working with the steps mentioned.

Then I try to follow steps in this page to reinstall laravel. What I learned in this page is to install laravel in /var/www/laravel instead of /var/www/html/laravel. The URL is now accessible without the public path and basic routing is working.

I hope a beginner like me found this blog and help him getting away from this frustration.

Installing laravel 5: http://blog.luutaa.com/cloud/setting-up-laravel-5-on-digital-ocean-ubuntu-on-apache/

Recommended tutorial: http://www.tutorials.kode-blog.com/laravel-hello-world

Posted By: Aeric
Last Edit: 08 Nov 2015 @ 12:42 AM

EmailPermalinkComments (0)
Tags

 Last 50 Posts
 Back
Change Theme...
  • Users » 2
  • Posts/Pages » 127
  • Comments » 200
Change Theme...
  • VoidVoid « Default
  • LifeLife
  • EarthEarth
  • WindWind
  • WaterWater
  • FireFire
  • LightLight